Linux 下多个 Python 版本造成 easy_install 出错

debian 默认有 python 2.5 ,我下了 2.73 的源码包自己编译安装了,也改了系统的默认调用

sudo rm /usr/bin/python
sudo ln -s /usr/lib/python2.73/python2.7 /usr/bin/python

这样确实可以默认启用 2.73 的 python ,但是后来使用

sudo apt-get install python-setuptools
sudo easy_install pip

的时候就报错,报 No module named pkg_resources

看起来像是找不到模块,猜想是 setuptools 安装到了 2.5 的下面去了,于是把软连接改回来,就可以正常使用 easy_install

问题是怎么让系统承认 2.73 并把 setuptools 装到新的里面去啊

Leave a Reply

Your email address will not be published. Required fields are marked *